Bug 56463 - Warning: no access to tty
Warning: no access to tty
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2001-11-19 07:18 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-25 06:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-19 07:18:09 EST
Description of Problem:

When I telnet into the machine, I often (almost always) get the messages:

Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.

and the shell does not work right (particularly with emacs).  It may have 
something to do with KDE and being logged in on the console or not.  

The problem occurs both for remote telnet and for local telnet (on same

I found a post on the web indicating that it was tied to newer kernels but, 
although I reverted back to kernel 2.4.2, it is still happening.  It did not 
happen earlier on a previous Redhat 7.0 installation.

Redhat support asked me to submit this bug report.  See support request 
194521.  They suggested switching to SSH which does not seem to have the 
problem.  I did that but would still like to see this resolved.

How Reproducible:

Nearly every time.  Logging in on console or logging out seems to affect 
chances of it happening for a remote connection.

Steps to Reproduce:

telnet to machine and it happens before .cshrc file is executed.

Actual Results:

Expected Results:

Additional Information:
Comment 1 Harald Hoyer 2001-11-19 08:04:23 EST
this seems to be a little bit csh related. Do you see this with bash also?
Comment 2 Need Real Name 2001-11-19 08:18:43 EST
I changed my login shell to bash and successfully logged in 4 times without 
hitting the problem.  When I logged in to another account that uses csh, the 
problem was there.  So, it does seem to be csh related too.
Comment 3 Harald Hoyer 2002-03-25 06:18:34 EST
this is fixed by using a more recent version of util-linux. the bug is in 'login'
Comment 4 Harald Hoyer 2002-03-25 06:21:24 EST

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.