Bug 564653 - FTBFS xesam-glib-0.5.0-3.fc12: ImplicitDSOLinking
FTBFS xesam-glib-0.5.0-3.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xesam-glib (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:29 EST by FTBFS
Modified: 2010-09-28 14:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 14:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (191.52 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
build.log (47.40 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
mock.log (963 bytes, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
root.log (237.80 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
build.log (46.34 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
mock.log (971 bytes, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
Sample spec update to use the forthcoming patches. (2.51 KB, text/plain)
2010-04-10 12:10 EDT, Bruno Wolff III
no flags Details
Makefile.in patch needed for build. (32.75 KB, patch)
2010-04-10 12:11 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch that should go upstream. (2.84 KB, patch)
2010-04-10 12:12 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:29:55 EST
xesam-glib-0.5.0-3.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:30:00 EST
Created attachment 390956 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:30:01 EST
Created attachment 390957 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:30:03 EST
Created attachment 390958 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:30:04 EST
Created attachment 390959 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:30:05 EST
Created attachment 390960 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:30:06 EST
Created attachment 390961 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:35:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-10 12:10:08 EDT
Created attachment 405729 [details]
Sample spec update to use the forthcoming patches.

I took a look at this as part of my Fedora Engineering Services task and was able to get it to build.
I am going to include a sample spec file. (I don't need credit, so you can change the changelog entry however you'd like.)
Also a patch for two Makefile.in files that are needed to get it to build.
Also a patch for two Makefile.am files, which ideally should be passed upstream.
Comment 9 Bruno Wolff III 2010-04-10 12:11:20 EDT
Created attachment 405730 [details]
Makefile.in patch needed for build.
Comment 10 Bruno Wolff III 2010-04-10 12:12:12 EDT
Created attachment 405731 [details]
Makefile.am patch that should go upstream.
Comment 11 Jan Klepek 2010-09-27 12:05:00 EDT
any progress on fixing this bug for fedora?
Comment 12 Deji Akingunola 2010-09-28 14:33:47 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.