Bug 564658 - FTBFS glabels-2.2.6-1.fc13: ImplicitDSOLinking
FTBFS glabels-2.2.6-1.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glabels (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:30 EST by FTBFS
Modified: 2010-04-27 01:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glabels-2.2.7-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 01:49:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (869.26 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
build.log (228.19 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:30 EST, FTBFS
no flags Details
root.log (1.27 MB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
build.log (222.65 KB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
mock.log (959 bytes, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
Patch for Makefile.in to get build to work. (596 bytes, patch)
2010-04-10 12:38 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch for upstream. (590 bytes, patch)
2010-04-10 12:39 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:30:51 EST
glabels-2.2.6-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:30:55 EST
Created attachment 390986 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:30:57 EST
Created attachment 390987 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:30:58 EST
Created attachment 390988 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:31:02 EST
Created attachment 390989 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:31:03 EST
Created attachment 390990 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:31:05 EST
Created attachment 390991 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:35:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-10 12:38:02 EDT
Created attachment 405735 [details]
Patch for Makefile.in to get build to work.

I took a look at this bug as part of my Fedora Engineering Services task and found that a couple of -lm's were needed. I am including a Makefile.in patch for getting things to build and a Makefile.am patch for upstream.
Comment 9 Bruno Wolff III 2010-04-10 12:39:05 EDT
Created attachment 405736 [details]
Makefile.am patch for upstream.
Comment 10 Jef Spaleta 2010-04-10 14:56:38 EDT
Thanks for the patch. it looks upstream has a new version. I'm going to get 2.2.7 building use the patch if necessary.

Sorry for the delay on responding. The initial fail to build report happened while I was at the end of the earth.

-jef
Comment 11 Fedora Update System 2010-04-17 22:59:41 EDT
glabels-2.2.7-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/glabels-2.2.7-1.fc13
Comment 12 Fedora Update System 2010-04-20 09:10:39 EDT
glabels-2.2.7-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glabels'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glabels-2.2.7-1.fc13
Comment 13 Fedora Update System 2010-04-27 01:49:38 EDT
glabels-2.2.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.