Bug 564660 - FTBFS gmpc-0.19.1-2.fc13: ImplicitDSOLinking
FTBFS gmpc-0.19.1-2.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmpc (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:31 EST by FTBFS
Modified: 2010-05-07 16:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 16:31:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (880.34 KB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
build.log (167.12 KB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
mock.log (942 bytes, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
root.log (1.26 MB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
build.log (163.46 KB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:31 EST, FTBFS
no flags Details
Patch for Makefile.in to get builds to work, (377 bytes, patch)
2010-04-10 13:21 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch for upstream. (217 bytes, patch)
2010-04-10 13:22 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:31:17 EST
gmpc-0.19.1-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:31:21 EST
Created attachment 390998 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:31:22 EST
Created attachment 390999 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:31:23 EST
Created attachment 391000 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:31:26 EST
Created attachment 391001 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:31:27 EST
Created attachment 391002 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:31:28 EST
Created attachment 391003 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:35:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-10 13:21:46 EDT
Created attachment 405738 [details]
Patch for Makefile.in to get builds to work,

As part of my Fedora Engineering Services task I took a look at this and found that -lz and -lX11 were needed to make this build. I am including a patch for Makefile.in to get this package to build and Makefile.am to send upstream.
Comment 9 Bruno Wolff III 2010-04-10 13:22:50 EDT
Created attachment 405739 [details]
Makefile.am patch for upstream.
Comment 10 Adrian Reber 2010-05-07 16:31:53 EDT
Thanks. Fixed in the development branch. In addition to your patch I also had to add "-lm".

Note You need to log in before you can comment on or make changes to this bug.