Bug 564689 - FTBFS scite-2.01-1.fc13: ImplicitDSOLinking
FTBFS scite-2.01-1.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scite (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: cq92j9y+rlkr0w
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:36 EST by FTBFS
Modified: 2010-04-20 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: scite-2.11-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-17 13:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (354.30 KB, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
build.log (78.52 KB, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
mock.log (940 bytes, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
root.log (509.09 KB, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
build.log (73.71 KB, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
mock.log (947 bytes, text/plain)
2010-02-13 11:36 EST, FTBFS
no flags Details
Add -ldl to link options (658 bytes, patch)
2010-04-10 15:12 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:36:36 EST
scite-2.01-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:36:39 EST
Created attachment 391157 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:36:40 EST
Created attachment 391158 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:36:42 EST
Created attachment 391159 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:36:43 EST
Created attachment 391160 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:36:44 EST
Created attachment 391161 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:36:46 EST
Created attachment 391162 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:37:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-10 15:12:54 EDT
Created attachment 405750 [details]
Add -ldl to link options

I took a look at this bug as part of my Fedora Engineering Services task.
It looks like a -ldl needs to get added to the link options. I am a attaching a patch to do that, but maybe you want to fold it into one of the other makefile patches being carried.
Comment 9 Fedora Update System 2010-04-17 13:10:06 EDT
scite-2.11-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/scite-2.11-1.fc13
Comment 10 cq92j9y+rlkr0w 2010-04-17 13:12:59 EDT
Hi Bruno:

I hope the new package I just built for F13 and rawhide fixes this.

https://koji.fedoraproject.org/koji/buildinfo?buildID=167589
https://admin.fedoraproject.org/updates/scite-2.11-1.fc13

Let me know if anything else is required. Thanks.
Comment 11 Fedora Update System 2010-04-20 09:23:35 EDT
scite-2.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.