Bug 56470 - mount fs bad report
Summary: mount fs bad report
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-19 16:11 UTC by acount closed by user
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-19 16:11:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description acount closed by user 2001-11-19 16:11:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
when I go to single mode from grub , then I remount / (ro) . mount report
(rw) but the output from /pro/mount  is (ro)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. single mode
2. mount -o  ro,remount /
3. mount ; cat /proc/mount
	

Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-11-20 15:25:30 UTC
This is expectable:
mount shows the content of /etc/mtab.
If /etc isn't writable, /etc/mtab can't be updated, therefore mount will 
display outdated content.

See the mount man page for details, including why having mount read 
/proc/mounts rather than /etc/mtab is not necessarily a good idea.


Comment 2 acount closed by user 2001-11-20 21:11:40 UTC
I think that /etc/mtab must be deleted every reboot at /etc/rc.d/init.d/halt
because when you are booting with root fs (/) in ro /etc/mtab must be empty
because _anything_ can write this file and it false the content.

well this example was not true:
--
1. single mode
2. mount -o  ro,remount /
3. mount ; cat /proc/mount
--

but if you are booting _emergency_ mode or with external media like a cdrom or
fd is true

Comment 3 acount closed by user 2001-11-20 21:22:14 UTC
"because _anything_ can write this file and it false the content."

change _anything_ for  "none process"

i am sorry, english is my third language



Note You need to log in before you can comment on or make changes to this bug.