Bug 564705 - FTBFS sectool-0.9.4-4.fc13: ImplicitDSOLinking
FTBFS sectool-0.9.4-4.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Maros Barabas
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:39 EST by FTBFS
Modified: 2010-04-20 08:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 08:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (401.70 KB, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
build.log (3.79 KB, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
mock.log (950 bytes, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
root.log (500.70 KB, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
build.log (3.78 KB, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
mock.log (959 bytes, text/plain)
2010-02-13 11:39 EST, FTBFS
no flags Details
Patch to add -lrpmio to link step (369 bytes, patch)
2010-04-10 15:46 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:39:42 EST
sectool-0.9.4-4.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:39:45 EST
Created attachment 391253 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:39:46 EST
Created attachment 391254 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:39:48 EST
Created attachment 391255 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:39:49 EST
Created attachment 391256 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:39:50 EST
Created attachment 391257 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:39:52 EST
Created attachment 391258 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:37:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-10 15:46:43 EDT
Created attachment 405751 [details]
Patch to add -lrpmio to link step

I looked at this bug as part of my Fedora Engineering Services task and it looks like adding -lrpmio to the link step will fix the problem.
Comment 9 Maros Barabas 2010-04-20 08:49:10 EDT
Fixed in F-13 and rawhide.

Note You need to log in before you can comment on or make changes to this bug.