Bug 564708 - FTBFS gnome-applet-window-picker-0.5.6-3.fc12: ImplicitDSOLinking
FTBFS gnome-applet-window-picker-0.5.6-3.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-applet-window-picker (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:40 EST by FTBFS
Modified: 2010-04-09 00:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-applet-window-picker-0.5.8-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-09 00:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (790.88 KB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details
build.log (21.78 KB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details
root.log (1.15 MB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details
build.log (21.59 KB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:40 EST, FTBFS
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 528296 None None None Never

  None (edit)
Description FTBFS 2010-02-13 11:40:16 EST
gnome-applet-window-picker-0.5.6-3.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:40:19 EST
Created attachment 391271 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:40:21 EST
Created attachment 391272 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:40:22 EST
Created attachment 391273 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:40:24 EST
Created attachment 391274 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:40:25 EST
Created attachment 391275 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:40:27 EST
Created attachment 391276 [details]
mock.log

mock.log for x86_64
Comment 7 Michel Alexandre Salim 2010-02-26 03:59:03 EST
Fixed in Rawhide, and upstreamed to Launchpad. Will close when F-13 build becomes a stable update
Comment 8 Fedora Update System 2010-02-26 04:07:27 EST
gnome-applet-window-picker-0.5.8-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-applet-window-picker-0.5.8-2.fc13
Comment 9 Fedora Update System 2010-02-26 22:35:56 EST
gnome-applet-window-picker-0.5.8-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applet-window-picker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-3034
Comment 10 Bug Zapper 2010-03-15 10:38:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bruno Wolff III 2010-03-27 16:49:01 EDT
This hasn't been pushed to stable yet. Is there an issue with the test version?
Comment 12 Fedora Update System 2010-04-09 00:01:59 EDT
gnome-applet-window-picker-0.5.8-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.