Bug 564720 - FTBFS mapnik-0.7.0-1.fc13: ImplicitDSOLinking
FTBFS mapnik-0.7.0-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mapnik (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:42 EST by FTBFS
Modified: 2010-07-03 21:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: mapnik-0.7.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-20 07:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (824.25 KB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
build.log (87.29 KB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
mock.log (947 bytes, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
root.log (1.19 MB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
build.log (82.82 KB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:42:27 EST
mapnik-0.7.0-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:42:30 EST
Created attachment 391340 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:42:32 EST
Created attachment 391341 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:42:33 EST
Created attachment 391342 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:42:35 EST
Created attachment 391343 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:42:37 EST
Created attachment 391344 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:42:38 EST
Created attachment 391345 [details]
mock.log

mock.log for x86_64
Comment 7 Alex Lancaster 2010-02-20 07:45:28 EST
Fixed in CVS and rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=157601

Closing bug.

Note You need to log in before you can comment on or make changes to this bug.