Bug 564723 - FTBFS dillo-0.8.6-11.fc12: ImplicitDSOLinking
FTBFS dillo-0.8.6-11.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dillo (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:42 EST by FTBFS
Modified: 2010-04-16 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: dillo-0.8.6-12.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-16 19:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (423.57 KB, text/plain)
2010-02-13 11:42 EST, FTBFS
no flags Details
build.log (120.04 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
root.log (653.55 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
build.log (118.74 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
Patch to add -lcrypto for i18n part of build (484 bytes, patch)
2010-04-11 05:12 EDT, Bruno Wolff III
no flags Details | Diff
Updated spec file (6.01 KB, text/plain)
2010-04-11 05:13 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:42:56 EST
dillo-0.8.6-11.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:42:59 EST
Created attachment 391355 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:43:01 EST
Created attachment 391356 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:43:02 EST
Created attachment 391357 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:43:03 EST
Created attachment 391358 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:43:05 EST
Created attachment 391359 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:43:06 EST
Created attachment 391360 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:38:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-11 02:57:43 EDT
I started looking at this as part of my Fedora Engineering Services task.
I think it won't be too hard to fix the missing -lcrypto, but I noticed that the spec file is building stuff outside the build root (or at least isn't cleaning up properly requiring manual cleanup between builds) which is bad. Doing the normal alternate build stuff won't work because you need two copies of the source, one of which gets heavily patched. I'd like to fix this at the same time.
I just need to think on it a bit.
Comment 9 Bruno Wolff III 2010-04-11 03:05:09 EDT
I think just an rm -rf is needed before the mv. setup normally does that before extracting and archive, so that's probably the right thing to do.
Comment 10 Bruno Wolff III 2010-04-11 05:12:48 EDT
Created attachment 405798 [details]
Patch to add -lcrypto for i18n part of build

I think I have something that works now. The problem part of the build was the i18n version. It seems to add an https option or an extra https feature compared to the normal version. And only -lssl was getting added, when -lcrypto was needed as well. So I have included a patch to src/Makefile.in that is only applied in the i18n part of the build. Since src/Makefile is already tweaked by the i18n patch, I am not going to try to add a Makefile.am patch since I don't think it would line up in any case.
I will also be attaching a sample spec file. It includes this patch and tries to removing existing i18n source in the BUILD directory if it already exists. This makes doing multiple rpmbuilds easier. There is a changelog entry for this which you are free to change; I don't need credit.
Comment 11 Bruno Wolff III 2010-04-11 05:13:37 EDT
Created attachment 405799 [details]
Updated spec file
Comment 12 Fedora Update System 2010-04-11 14:33:00 EDT
dillo-0.8.6-12.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/dillo-0.8.6-12.fc13
Comment 13 Bruno Wolff III 2010-04-11 14:42:09 EDT
Thanks for making the build.
Comment 14 Fedora Update System 2010-04-12 21:52:03 EDT
dillo-0.8.6-12.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dillo'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dillo-0.8.6-12.fc13
Comment 15 Fedora Update System 2010-04-16 19:48:25 EDT
dillo-0.8.6-12.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.