This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 564725 - FTBFS padevchooser-0.9.4-0.11.svn20070925.fc13: ImplicitDSOLinking
FTBFS padevchooser-0.9.4-0.11.svn20070925.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: padevchooser (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:43 EST by FTBFS
Modified: 2011-03-22 06:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-22 06:48:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (832.20 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
build.log (11.16 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
mock.log (1.07 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
root.log (1.22 MB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
build.log (11.09 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:43 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:43:17 EST
padevchooser-0.9.4-0.11.svn20070925.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:43:21 EST
Created attachment 391367 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:43:25 EST
Created attachment 391368 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:43:26 EST
Created attachment 391369 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:43:28 EST
Created attachment 391370 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:43:30 EST
Created attachment 391371 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:43:31 EST
Created attachment 391372 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:38:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Aioanei Rares 2010-08-23 11:55:37 EDT
Adding libX11-devel to BuildRequires and changing the make flags in order to look like this  make LIBS=-lX11 LDFLAGS=-L/usr/lib64 %{?_smp_mflags} in the specfile
solves the issue.
Comment 9 Aioanei Rares 2010-08-23 12:21:20 EDT
Adding libX11-devel to BuildRequires and changing the make flags in order to look like this  make LIBS=-lX11 LDFLAGS=-L/usr/lib64 %{?_smp_mflags} in the specfile
solves the issue.
Comment 10 Alexander Kurtakov 2011-03-22 06:48:23 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=220315

Note You need to log in before you can comment on or make changes to this bug.