Bug 564733 - FTBFS easystroke-0.5.2-1.fc13
Summary: FTBFS easystroke-0.5.2-1.fc13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easystroke
Version: 13
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Depends On:
Blocks: F13FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-02-13 16:44 UTC by FTBFS
Modified: 2010-03-20 03:50 UTC (History)
3 users (show)

Fixed In Version: easystroke-0.5.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-20 03:50:07 UTC
Type: ---


Attachments (Terms of Use)
root.log (655.25 KB, text/plain)
2010-02-13 16:44 UTC, FTBFS
no flags Details
build.log (11.39 KB, text/plain)
2010-02-13 16:44 UTC, FTBFS
no flags Details
mock.log (963 bytes, text/plain)
2010-02-13 16:45 UTC, FTBFS
no flags Details
root.log (953.48 KB, text/plain)
2010-02-13 16:45 UTC, FTBFS
no flags Details
build.log (8.51 KB, text/plain)
2010-02-13 16:45 UTC, FTBFS
no flags Details
mock.log (971 bytes, text/plain)
2010-02-13 16:45 UTC, FTBFS
no flags Details

Description FTBFS 2010-02-13 16:44:54 UTC
easystroke-0.5.2-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 16:44:58 UTC
Created attachment 391415 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 16:44:59 UTC
Created attachment 391416 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 16:45:00 UTC
Created attachment 391417 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 16:45:02 UTC
Created attachment 391418 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 16:45:04 UTC
Created attachment 391419 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 16:45:05 UTC
Created attachment 391420 [details]
mock.log

mock.log for x86_64

Comment 7 Petr Machata 2010-02-22 13:46:13 UTC
The cause of the first failure is boost 1.41.  I'm building an update that should fix this right now.  Then it fails due to
  http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
The libraries that need to be added to the linker command line are
  -lX11 -lXext -lXi -lXfixes

Comment 8 Alex Lancaster 2010-03-06 00:58:58 UTC
This needs to be fixed ASAP, it's causing broken deps in both branched F-13:

http://koji.fedoraproject.org/mash/branched-20100305/logs/depcheck

as well as rawhide F-14:

http://koji.fedoraproject.org/mash/rawhide-20100305/logs/depcheck

I am attempting an F-13 build as we speak to get this fixed before release and if I don't hear anything from the maintainer I will try to push this through bodhi.

Comment 9 Alex Lancaster 2010-03-06 01:13:37 UTC
(In reply to comment #7)
> The cause of the first failure is boost 1.41.  I'm building an update that
> should fix this right now.  Then it fails due to
>   http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
> The libraries that need to be added to the linker command line are
>   -lX11 -lXext -lXi -lXfixes    

Petr: do you have patches available that can actually fix this as you implied comment #7?  If you do and you aren't already a co-maintainer and can add them yourself, please post them here, and if the maintainer doesn't respond ASAP, I can patch, build and push the update via bodhi to fix the broken deps.  

If are a co-maintainer please build for rawhide (devel/) branch and again for F-13 and do a bodhi update to fix the broken deps.

Comment 10 Zarko (grof) 2010-03-06 16:48:58 UTC
I am the current maintainer , but I wrote before about my leaving from packaging for Fedora because of my personal reasons.

So maybe it is the good time to find another maintainer for this package.

If someone want to take this package I'll be very happy. 

kind regards,

Zarko

Comment 11 Petr Machata 2010-03-08 11:16:20 UTC
> Petr: do you have patches available that can actually fix this as you implied
> comment #7?  If you do and you aren't already a co-maintainer and can add them

No, I just launched the link command line manually.

> yourself, please post them here, and if the maintainer doesn't respond ASAP, I
> can patch, build and push the update via bodhi to fix the broken deps.  
> 
> If are a co-maintainer please build for rawhide (devel/) branch and again for
> F-13 and do a bodhi update to fix the broken deps.    

No, I'm not a co-maintainer.  Just wanted to make sure that it builds with the new boost.

Comment 12 Bug Zapper 2010-03-15 14:39:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Fedora Update System 2010-03-17 19:17:19 UTC
easystroke-0.5.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/easystroke-0.5.3-1.fc13

Comment 14 Fedora Admin XMLRPC Client 2010-03-17 19:18:55 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 15 Tom "spot" Callaway 2010-03-17 19:19:44 UTC
Got tired of seeing this one broken and just fixed it. I also took ownership.

Comment 16 Fedora Update System 2010-03-20 03:50:02 UTC
easystroke-0.5.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.