Bug 56474 - srpm faild to build
Summary: srpm faild to build
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-19 17:17 UTC by Jackie Meese
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 19:20:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jackie Meese 2001-11-19 17:17:55 UTC
Description of Problem:

rebuild of this package fails on executing install step

Version-Release number of selected component (if applicable):
1999082

How Reproducible:
Every time

Steps to Reproduce:
1. rpm --rebuild console-tools-19990829-36.src.rpm

Actual Results:
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.7005
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd console-tools-0.3.3
+ rm -rf /var/tmp/console-tools-19990829-root
+ mkdir -p /var/tmp/console-tools-19990829-root/usr
/var/tmp/console-tools-19990829-root/lib/kbd
+ find doc console-data-1999.08.29/doc -size 0b
+ xargs rm -f
rm: `doc' is a directory
rm: `doc/fonts' is a directory
rm: `doc/file-formats' is a directory
rm: `doc/man' is a directory
rm: `doc/dvorak' is a directory
rm: `doc/contrib' is a directory
rm: `console-data-1999.08.29/doc' is a directory
rm: `console-data-1999.08.29/doc/keymaps' is a directory
rm: `console-data-1999.08.29/doc/fonts' is a directory
error: Bad exit status from /var/tmp/rpm-tmp.7005 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.7005 (%install)


Expected Results:
builds package

Additional Information:
patch attached

Comment 1 Jackie Meese 2001-11-19 17:19:45 UTC
--- console-tools.spec.old      Wed Sep  5 20:08:10 2001
+++ console-tools.spec  Mon Nov 19 12:12:15 2001
@@ -158,7 +158,7 @@
 mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT/lib/kbd
 
 # Don't ship zero-length documentation
-find doc %{DATA}/doc -size 0b | xargs rm -f
+find doc %{DATA}/doc -type f -size 0b | xargs rm -f
 
 cd %{DATA}
 make install prefix=$RPM_BUILD_ROOT/usr datadir=$RPM_BUILD_ROOT/lib/kbd


Comment 2 Jackie Meese 2001-11-19 20:37:16 UTC
ok, seems to work a friend's machine w/o changing srpm, custom 2.4.13 kernel, RH 7.1

not a bug?  or is it still worth it?


Comment 3 Bernhard Rosenkraenzer 2001-11-20 15:04:49 UTC
Hm, works for me... By any chance are you using an ancient version of rpm?


Comment 4 Eido Inoue 2004-11-05 19:20:31 UTC
not seeing this with most recent/current rpmbuild and/or console-tools


Note You need to log in before you can comment on or make changes to this bug.