This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 564742 - FTBFS gpsdrive-2.10-0.5.pre7.fc13: ImplicitDSOLinking
FTBFS gpsdrive-2.10-0.5.pre7.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpsdrive (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:46 EST by FTBFS
Modified: 2010-05-10 19:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: gpsdrive-2.10-0.6.pre7.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 19:47:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (801.79 KB, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
build.log (57.40 KB, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
root.log (1.09 MB, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
build.log (56.25 KB, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
mock.log (981 bytes, text/plain)
2010-02-13 11:46 EST, FTBFS
no flags Details
gpsdrive-2.10-fix-dso-linking.patch (721 bytes, patch)
2010-05-09 20:22 EDT, Hicham HAOUARI
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:46:42 EST
gpsdrive-2.10-0.5.pre7.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:46:46 EST
Created attachment 391469 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:46:47 EST
Created attachment 391470 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:46:48 EST
Created attachment 391471 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:46:50 EST
Created attachment 391472 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:46:52 EST
Created attachment 391473 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:46:53 EST
Created attachment 391474 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:39:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Kevin Fenzi 2010-05-09 17:34:35 EDT
Sorry for ignoring this so long. ;( 

I had a chance to poke at it some today. It's kinda a mess. ;) 

I have a patch that gets past most of the problems, but it gets stuck on boost, and I can't grok the cmake file for Boost thats included. 

If anyone would like to dig further: 

http://www.scyre.com/~kevin/fedora/gpsdrive/gpsdrive-2.10-0.6.20100508svn.fc14.src.rpm
Comment 9 Hicham HAOUARI 2010-05-09 20:04:53 EDT
fixed

http://koji.fedoraproject.org/koji/taskinfo?taskID=2176153
Comment 10 Hicham HAOUARI 2010-05-09 20:22:57 EDT
Created attachment 412689 [details]
gpsdrive-2.10-fix-dso-linking.patch
Comment 11 Fedora Update System 2010-05-10 15:26:08 EDT
gpsdrive-2.10-0.6.pre7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gpsdrive-2.10-0.6.pre7.fc13
Comment 12 Fedora Update System 2010-05-10 19:47:38 EDT
gpsdrive-2.10-0.6.pre7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.