Bug 564755 - FTBFS pokerth-0.7.1-3.fc13: ImplicitDSOLinking
FTBFS pokerth-0.7.1-3.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pokerth (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:49 EST by FTBFS
Modified: 2010-06-14 03:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-13 21:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (698.56 KB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
build.log (222.11 KB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
root.log (1.04 MB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
build.log (216.44 KB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:49 EST, FTBFS
no flags Details
Patch to fix build error (3.23 KB, patch)
2010-06-13 04:59 EDT, Brad Hubbard
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:49:10 EST
pokerth-0.7.1-3.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:49:14 EST
Created attachment 391547 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:49:15 EST
Created attachment 391548 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:49:16 EST
Created attachment 391549 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:49:19 EST
Created attachment 391550 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:49:20 EST
Created attachment 391551 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:49:21 EST
Created attachment 391552 [details]
mock.log

mock.log for x86_64
Comment 8 Bug Zapper 2010-03-15 10:39:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Brad Hubbard 2010-06-13 04:59:06 EDT
Created attachment 423603 [details]
Patch to fix build error

As part of a Fedora Engineering Services task I took a look at this and modified two .pro files to include some libraries that were not being included automatically. Please forward the patch upstream.
Comment 10 Susi Lehtola 2010-06-13 21:02:22 EDT
Ugh, sorry. I fixed this 10 days ago, but didn't notice there was a bug in bugzilla for this.
Comment 11 Brad Hubbard 2010-06-14 03:46:40 EDT
Never mind, glad it is actively maintained. All the best.

Note You need to log in before you can comment on or make changes to this bug.