Bug 564802 - FTBFS unbound-1.4.1-1.fc13: ImplicitDSOLinking
FTBFS unbound-1.4.1-1.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: unbound (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583275
  Show dependency treegraph
 
Reported: 2010-02-13 11:57 EST by FTBFS
Modified: 2010-04-26 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: unbound-1.4.3-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 19:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (77.55 KB, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details
build.log (104.75 KB, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details
mock.log (951 bytes, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details
root.log (125.50 KB, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details
build.log (95.20 KB, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details
mock.log (959 bytes, text/plain)
2010-02-13 11:57 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:57:28 EST
unbound-1.4.1-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:57:31 EST
Created attachment 391810 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:57:32 EST
Created attachment 391811 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:57:33 EST
Created attachment 391812 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:57:34 EST
Created attachment 391813 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:57:35 EST
Created attachment 391814 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:57:36 EST
Created attachment 391815 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:42:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora Update System 2010-04-09 00:48:28 EDT
unbound-1.4.3-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/unbound-1.4.3-1.el5
Comment 9 Fedora Update System 2010-04-09 18:57:33 EDT
unbound-1.4.3-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update unbound'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/unbound-1.4.3-1.el5
Comment 10 Fedora Update System 2010-04-26 19:27:43 EDT
unbound-1.4.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.