Bug 564812 - FTBFS asymptote-1.90-1.fc13: ImplicitDSOLinking
FTBFS asymptote-1.90-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asymptote (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:59 EST by FTBFS
Modified: 2010-02-19 15:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-19 15:02:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (609.30 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details
build.log (36.68 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details
root.log (806.18 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details
build.log (33.43 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details
mock.log (1.02 KB, text/plain)
2010-02-13 11:59 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:59:16 EST
asymptote-1.90-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:59:19 EST
Created attachment 391867 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:59:20 EST
Created attachment 391868 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:59:22 EST
Created attachment 391869 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:59:23 EST
Created attachment 391870 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:59:25 EST
Created attachment 391871 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:59:26 EST
Created attachment 391872 [details]
mock.log

mock.log for x86_64
Comment 7 Tom "spot" Callaway 2010-02-19 15:02:17 EST
Fixed in rawhide:
http://koji.fedoraproject.org/koji/buildinfo?buildID=157498

(Yes, I know that's F-13, as opposed to devel, but it failed in devel because of broken deps involving ghostscript, and would have succeeded otherwise.)

Note You need to log in before you can comment on or make changes to this bug.