Bug 564819 - FTBFS xfce4-screenshooter-1.7.9-1.fc13: ImplicitDSOLinking
FTBFS xfce4-screenshooter-1.7.9-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-screenshooter (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583275
  Show dependency treegraph
 
Reported: 2010-02-13 12:00 EST by FTBFS
Modified: 2010-05-20 11:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.7.9-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 11:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (831.96 KB, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details
build.log (56.57 KB, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details
mock.log (999 bytes, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details
root.log (1.12 MB, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details
build.log (55.77 KB, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details
mock.log (1.06 KB, text/plain)
2010-02-13 12:00 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:00:38 EST
xfce4-screenshooter-1.7.9-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:00:43 EST
Created attachment 391906 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:00:44 EST
Created attachment 391907 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:00:45 EST
Created attachment 391908 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:00:50 EST
Created attachment 391909 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:00:51 EST
Created attachment 391910 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:00:52 EST
Created attachment 391911 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:42:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Roland Grunberg 2010-05-12 15:04:51 EDT
Was able to get this building with the following change :

--- xfce4-screenshooter-1.7.9-dsofix.patch.old	2010-05-12 10:19:41.000000000 -0400
+++ xfce4-screenshooter-1.7.9-dsofix.patch	2010-05-12 10:10:11.000000000 -0400
@@ -5,7 +5,7 @@
  INTLTOOL_UPDATE = @INTLTOOL_UPDATE@
  LD = @LD@
 -LDFLAGS = @LDFLAGS@
-+LDFLAGS = @LDFLAGS@ -lX11
++LDFLAGS = @LDFLAGS@ -lX11 -lm -lXext
  LIBOBJS = @LIBOBJS@
  LIBS = @LIBS@
  LIBTOOL = @LIBTOOL@
Comment 9 Christoph Wickert 2010-05-20 11:45:20 EDT
Sorry for the late response. This should have fixed long ago, I already had this in my local cvs. Thanks Roland!

Fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=157082

Note You need to log in before you can comment on or make changes to this bug.