Bug 564840 - FTBFS xfce4-sensors-plugin-0.10.99.6-5.fc12: ImplicitDSOLinking
FTBFS xfce4-sensors-plugin-0.10.99.6-5.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-sensors-plugin (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
: 599782 (view as bug list)
Depends On:
Blocks: 564245 583275 F14FTBFS
  Show dependency treegraph
 
Reported: 2010-02-13 12:04 EST by FTBFS
Modified: 2010-06-10 15:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: xfce4-sensors-plugin-1.0.0-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 20:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (842.86 KB, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
build.log (48.11 KB, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
mock.log (1.07 KB, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
root.log (1.13 MB, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
build.log (48.06 KB, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
mock.log (1023 bytes, text/plain)
2010-02-13 12:04 EST, FTBFS
no flags Details
xfce4-sensors-plugin-1.0.0-dso.patch (7.29 KB, patch)
2010-06-03 20:01 EDT, Robert Scheck
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6492 None None None Never

  None (edit)
Description FTBFS 2010-02-13 12:04:33 EST
xfce4-sensors-plugin-0.10.99.6-5.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:04:38 EST
Created attachment 392032 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:04:39 EST
Created attachment 392033 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:04:40 EST
Created attachment 392034 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:04:43 EST
Created attachment 392035 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:04:44 EST
Created attachment 392036 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:04:45 EST
Created attachment 392037 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:43:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Christoph Wickert 2010-06-03 16:42:22 EDT
*** Bug 599782 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2010-06-03 16:44:58 EDT
Changing version back to rawhide.
Comment 10 Robert Scheck 2010-06-03 20:01:35 EDT
Created attachment 421072 [details]
xfce4-sensors-plugin-1.0.0-dso.patch

Patch solving this issue for me. The first two hunks should get upstream,
the patch can be used on downstream with and without running autotools...
Comment 11 Christoph Wickert 2010-06-03 20:51:51 EDT
Thanks for the patch, Robert. I have forwarded it upstream at
http://bugzilla.xfce.org/show_bug.cgi?id=6492
Comment 12 Fedora Update System 2010-06-03 21:21:32 EDT
xfce4-sensors-plugin-1.0.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xfce4-sensors-plugin-1.0.0-1.fc13
Comment 13 Fedora Update System 2010-06-10 15:17:48 EDT
xfce4-sensors-plugin-1.0.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.