Bug 564845 - FTBFS rss-glx-0.9.1.p-2.fc13: ImplicitDSOLinking
FTBFS rss-glx-0.9.1.p-2.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rss-glx (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:05 EST by FTBFS
Modified: 2010-04-11 13:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-11 13:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (548.62 KB, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details
build.log (52.48 KB, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details
mock.log (956 bytes, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details
root.log (802.85 KB, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details
build.log (48.69 KB, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details
mock.log (966 bytes, text/plain)
2010-02-13 12:05 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:05:34 EST
rss-glx-0.9.1.p-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:05:37 EST
Created attachment 392062 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:05:39 EST
Created attachment 392063 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:05:40 EST
Created attachment 392064 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:05:42 EST
Created attachment 392065 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:05:43 EST
Created attachment 392066 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:05:44 EST
Created attachment 392067 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:43:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Caolan McNamara 2010-04-11 13:55:31 EDT
Added rss-glx-0.9.1.p-linker.patch to force using $(CXX) as the linker for pixelcity which by default uses $(CC) as its only comprised from .c files, but we need to link it against a c++ library. Built as rss-glx-0.9.1.p-3.fc14

Note You need to log in before you can comment on or make changes to this bug.