Bug 564861 - FTBFS nss-ldapd-0.6.11-2.fc12: ImplicitDSOLinking
FTBFS nss-ldapd-0.6.11-2.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss-ldapd (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:08 EST by FTBFS
Modified: 2010-02-17 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version: nss-ldapd-0.6.11-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 18:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (143.55 KB, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details
build.log (20.11 KB, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details
mock.log (962 bytes, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details
root.log (182.04 KB, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details
build.log (18.63 KB, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details
mock.log (970 bytes, text/plain)
2010-02-13 12:08 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:08:31 EST
nss-ldapd-0.6.11-2.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:08:34 EST
Created attachment 392149 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:08:36 EST
Created attachment 392150 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:08:37 EST
Created attachment 392151 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:08:38 EST
Created attachment 392152 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:08:39 EST
Created attachment 392153 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:08:40 EST
Created attachment 392154 [details]
mock.log

mock.log for x86_64
Comment 7 Nalin Dahyabhai 2010-02-17 18:38:07 EST
Fixed in nss-ldapd-0.6.11-3.fc13, though if someone has time, bug #555121 could use some package review TLC.

Note You need to log in before you can comment on or make changes to this bug.