Bug 564867 - FTBFS gir-repository-0.6.5-5.fc13: ImplicitDSOLinking
FTBFS gir-repository-0.6.5-5.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gir-repository (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:09 EST by FTBFS
Modified: 2010-03-03 12:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-03 12:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (1.12 MB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details
build.log (35.19 KB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details
root.log (1.64 MB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details
build.log (33.91 KB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details
mock.log (1.04 KB, text/plain)
2010-02-13 12:09 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:09:40 EST
gir-repository-0.6.5-5.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:09:44 EST
Created attachment 392185 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:09:46 EST
Created attachment 392186 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:09:47 EST
Created attachment 392187 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:09:50 EST
Created attachment 392188 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:09:51 EST
Created attachment 392189 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:09:52 EST
Created attachment 392190 [details]
mock.log

mock.log for x86_64
Comment 7 Bastien Nocera 2010-03-02 13:33:03 EST
Introspection needs to be enabled in GStreamer packages themselves and disabled in gir-repository.
Comment 8 Peter Robinson 2010-03-03 12:23:17 EST
Fixed for rawhide and F-13

* Wed Mar  3 2010 Peter Robinson <pbrobinson@gmail.com> 0.6.5-6
- Add patch to fix babl version
- Fix FTBFS - Fixes 564867
- Drop gstreamer as it should be enabled in gst itself

Note You need to log in before you can comment on or make changes to this bug.