This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 564876 - FTBFS 389-ds-base-1.2.6-0.1.a1.fc13: ImplicitDSOLinking
FTBFS 389-ds-base-1.2.6-0.1.a1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: 389-ds-base (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: screened, Triaged
Depends On:
Blocks: 434915 389_1.2.6 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:11 EST by FTBFS
Modified: 2011-04-25 19:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 16:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (265.55 KB, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
build.log (1.06 MB, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
root.log (378.74 KB, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
build.log (1.04 MB, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
mock.log (990 bytes, text/plain)
2010-02-13 12:11 EST, FTBFS
no flags Details
fix to lpthread FTBFS (1.19 KB, patch)
2010-02-19 04:59 EST, Ankur Sinha (FranciscoD)
no flags Details | Diff
patch for spec (330 bytes, patch)
2010-02-19 05:01 EST, Ankur Sinha (FranciscoD)
no flags Details | Diff
patch for upstream source (11.13 KB, patch)
2010-02-24 17:34 EST, Rich Megginson
nhosoi: review+
Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:11:33 EST
389-ds-base-1.2.6-0.1.a1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:11:36 EST
Created attachment 392239 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:11:38 EST
Created attachment 392240 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:11:40 EST
Created attachment 392241 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:11:41 EST
Created attachment 392242 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:11:44 EST
Created attachment 392243 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:11:45 EST
Created attachment 392244 [details]
mock.log

mock.log for x86_64
Comment 7 Ankur Sinha (FranciscoD) 2010-02-19 04:59:17 EST
Created attachment 395059 [details]
fix to lpthread FTBFS

this patch fixes the FTBFS implicit DSO for lpthread
Comment 8 Ankur Sinha (FranciscoD) 2010-02-19 05:01:03 EST
Created attachment 395061 [details]
patch for spec
Comment 9 Rich Megginson 2010-02-24 17:34:50 EST
Created attachment 396176 [details]
patch for upstream source
Comment 10 Rich Megginson 2010-02-25 12:19:13 EST
pushed to master

commit 1ce1a045b77d2726ab1cb52a3e5ad943976d0fa8
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Feb 24 15:12:05 2010 -0700

    Reviewed by: nhosoi (Thanks!)
Comment 11 Bug Zapper 2010-03-15 10:45:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bruno Wolff III 2010-03-27 16:54:14 EDT
This appears safe to close now.
Thanks for fixing things.

Note You need to log in before you can comment on or make changes to this bug.