Bug 564898 - FTBFS xfhell-1.9-3.fc12: ImplicitDSOLinking
FTBFS xfhell-1.9-3.fc12: ImplicitDSOLinking
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfhell (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Robert 'Bob' Jensen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583275
  Show dependency treegraph
 
Reported: 2010-02-13 12:15 EST by FTBFS
Modified: 2011-03-13 15:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-13 15:25:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (353.92 KB, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
build.log (17.11 KB, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
mock.log (940 bytes, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
root.log (508.77 KB, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
build.log (16.60 KB, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
mock.log (949 bytes, text/plain)
2010-02-13 12:15 EST, FTBFS
no flags Details
Patch for xfhell configure.in (299 bytes, text/plain)
2010-05-12 10:20 EDT, Charley Wang
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:15:24 EST
xfhell-1.9-3.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:15:27 EST
Created attachment 392359 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:15:29 EST
Created attachment 392360 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:15:30 EST
Created attachment 392361 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:15:32 EST
Created attachment 392362 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:15:33 EST
Created attachment 392363 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:15:35 EST
Created attachment 392364 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:46:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Charley Wang 2010-05-12 10:20:40 EDT
Created attachment 413436 [details]
Patch for xfhell configure.in

I've attached a small patch to this package's configuration that resolves the linker issues. I am able to successfully resolve the linker issues by appling this patch and running aclocal;automake;autoconf to reconfigure.

If you like, I can do a direct commit of this patch.

-Charley
Comment 9 Jan Klepek 2011-03-13 15:25:42 EDT
closing as package could be build without problem

Note You need to log in before you can comment on or make changes to this bug.