Bug 564919 - FTBFS rakarrack-0.3.0-5.fc13: ImplicitDSOLinking
FTBFS rakarrack-0.3.0-5.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rakarrack (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:18 EST by FTBFS
Modified: 2010-06-21 17:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: rakarrack-0.4.2-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 17:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (422.78 KB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
build.log (33.99 KB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
mock.log (1021 bytes, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
root.log (627.17 KB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
build.log (32.06 KB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
mock.log (967 bytes, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:18:59 EST
rakarrack-0.3.0-5.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:19:03 EST
Created attachment 392475 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:19:04 EST
Created attachment 392476 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:19:05 EST
Created attachment 392477 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:19:07 EST
Created attachment 392478 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:19:08 EST
Created attachment 392479 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:19:10 EST
Created attachment 392480 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:47:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 David Timms 2010-04-05 10:21:17 EDT
(In reply to comment #7)
> More information and reason for this action is here:
> http://fedoraproject.org/wiki/BugZappers/HouseKeeping    
A patch has been added to configure.in to add a check for libX11 to the build process. rakarrack now builds and runs on F13 environment.
Comment 9 Fedora Update System 2010-04-08 19:18:47 EDT
rakarrack-0.4.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rakarrack-0.4.2-2.fc13
Comment 10 Fedora Update System 2010-04-08 23:54:57 EDT
rakarrack-0.4.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rakarrack'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/rakarrack-0.4.2-2.fc13
Comment 11 Fedora Update System 2010-06-21 17:46:13 EDT
rakarrack-0.4.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.