Bug 564920 - FTBFS kdeedu-4.4.0-1.fc13: ImplicitDSOLinking
FTBFS kdeedu-4.4.0-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libqalculate (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:19 EST by FTBFS
Modified: 2010-02-14 14:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-14 14:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (1.24 MB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
build.log (4.36 MB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
mock.log (948 bytes, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
root.log (1.79 MB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
build.log (4.29 MB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 12:19 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:19:11 EST
kdeedu-4.4.0-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:19:16 EST
Created attachment 392481 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:19:23 EST
Created attachment 392482 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:19:24 EST
Created attachment 392483 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:19:28 EST
Created attachment 392484 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:19:34 EST
Created attachment 392485 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:19:35 EST
Created attachment 392486 [details]
mock.log

mock.log for x86_64
Comment 7 Rex Dieter 2010-02-13 17:41:28 EST
interesting, missing symbols from cln, but no references to cln functions or headers to be found.  maybe a define or inline stuff from libqalculate?
Comment 8 Rex Dieter 2010-02-13 17:46:48 EST
In particular,
cd /builddir/build/BUILD/kdeedu-4.4.0/x86_64-redhat-linux-gnu/step/step && 
...
/messageframe.o CMakeFiles/step.dir/main.o CMakeFiles/step.dir/settings.o  -o step -rdynamic -L/usr/lib64/kde4/devel -L/builddir/build/BUILD/kdeedu-4.4.0/x86_64-redhat-linux-gnu/lib ../../lib/libstepcore.a /usr/lib64/libkhtml.so.5.4.0 /usr/lib64/libknewstuff2.so.4.4.0 /usr/lib64/libQtOpenGL.so -lqalculate -lgsl -lgslcblas -lm -lz -lgthread-2.0 -lglib-2.0 -lgobject-2.0 -lrt -ldl /usr/lib64/libkparts.so.4.4.0 /usr/lib64/libkjs.so.4.4.0 /usr/lib64/libkio.so.5.4.0 /usr/lib64/libQtXml.so /usr/lib64/libQtNetwork.so /usr/lib64/libkdeui.so.5.4.0 /usr/lib64/libQtSvg.so /usr/lib64/libkdecore.so.5.4.0 /usr/lib64/libQtCore.so -lpthread /usr/lib64/libQtDBus.so /usr/lib64/libQtGui.so -Wl,-rpath,/usr/lib64/kde4/devel: 
/usr/bin/ld: CMakeFiles/step.dir/unitscalc.o: undefined reference to symbol 'cln::cl_GV_number_init_helper::~cl_GV_number_init_helper()'
/usr/bin/ld: note: 'cln::cl_GV_number_init_helper::~cl_GV_number_init_helper()' is defined in DSO /usr/lib64/libcln.so.6 so try adding it to the linker command line
/usr/lib64/libcln.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

any ideas?
Comment 9 Kevin Kofler 2010-02-13 17:48:02 EST
The inlines from libqalculate must be using cln, I guess you need to link cln when you link libqalculate (this just shows how broken this crappy ld change is for C++).
Comment 10 Kevin Kofler 2010-02-13 17:56:45 EST
pkg-config --libs libqalculate returns only -lqalculate, looks like it needs to -lcln as well.
Comment 11 Kevin Kofler 2010-02-13 18:01:04 EST
Oops, I didn't mean to reassign this back, it's clearly libqalculate's fault.
Comment 12 Rex Dieter 2010-02-13 18:17:16 EST
that's probably my bad, see bug #509840
Comment 13 Kevin Kofler 2010-02-13 18:21:57 EST
Yeah, at least @CLN_LIBS@ should go back to Libs.
Comment 14 Rex Dieter 2010-02-13 18:32:20 EST
Cross your fingers,
https://koji.fedoraproject.org/koji/taskinfo?taskID=1984629

Note You need to log in before you can comment on or make changes to this bug.