Bug 564927 - FTBFS kdissert-1.0.7-6.fc12: ImplicitDSOLinking
FTBFS kdissert-1.0.7-6.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdissert (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:20 EST by FTBFS
Modified: 2010-05-05 03:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: kdissert-1.0.7-7.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 03:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (650.14 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
build.log (23.72 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
mock.log (954 bytes, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
root.log (932.13 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
build.log (23.61 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
mock.log (963 bytes, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:20:42 EST
kdissert-1.0.7-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:20:46 EST
Created attachment 392523 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:20:48 EST
Created attachment 392524 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:20:49 EST
Created attachment 392525 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:20:51 EST
Created attachment 392526 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:20:52 EST
Created attachment 392527 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:20:53 EST
Created attachment 392528 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:48:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:18:05 EDT
Hi,

Any progress with this bug?
Comment 9 Rex Dieter 2010-05-04 18:17:39 EDT
Oh my, didn't recall owning this package.  I'll take a look.
Comment 10 Rex Dieter 2010-05-04 18:52:44 EDT
Ugh, missing -lkdeui , but can't get waf to cooperate.
Comment 11 Fedora Update System 2010-05-04 19:54:49 EDT
kdissert-1.0.7-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kdissert-1.0.7-7.fc13
Comment 12 Fedora Update System 2010-05-05 03:21:40 EDT
kdissert-1.0.7-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.