Bug 564928 - FTBFS gtorrentviewer-0.2b-18.fc12: ImplicitDSOLinking
FTBFS gtorrentviewer-0.2b-18.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtorrentviewer (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:20 EST by FTBFS
Modified: 2010-02-23 11:05 EST (History)
1 user (show)

See Also:
Fixed In Version: gtorrentviewer-0.2b-19.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 11:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (630.90 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
build.log (12.52 KB, text/plain)
2010-02-13 12:20 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 12:21 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:20:55 EST
gtorrentviewer-0.2b-18.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:20:58 EST
Created attachment 392529 [details]
root.log

root.log for x86_64
Comment 2 FTBFS 2010-02-13 12:20:59 EST
Created attachment 392530 [details]
build.log

build.log for x86_64
Comment 3 FTBFS 2010-02-13 12:21:00 EST
Created attachment 392531 [details]
mock.log

mock.log for x86_64
Comment 4 Paul Howarth 2010-02-23 08:43:30 EST
This problem is due to mainwindow.c calling ceil() but the resulting binary not being linked with libm. Fixed in -19.
Comment 5 Fedora Update System 2010-02-23 08:46:11 EST
gtorrentviewer-0.2b-19.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gtorrentviewer-0.2b-19.fc13
Comment 6 Fedora Update System 2010-02-23 11:05:21 EST
gtorrentviewer-0.2b-19.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.