Bug 564945 - FTBFS driftnet-0.1.6-19.20040426cvs.fc12: ImplicitDSOLinking
Summary: FTBFS driftnet-0.1.6-19.20040426cvs.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: driftnet
Version: 13
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
: 599847 (view as bug list)
Depends On:
Blocks: 564245 583276
TreeView+ depends on / blocked
 
Reported: 2010-02-13 17:24 UTC by FTBFS
Modified: 2010-11-10 01:17 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-10 01:07:35 UTC


Attachments (Terms of Use)
root.log (374.37 KB, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
build.log (11.74 KB, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
mock.log (994 bytes, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
root.log (549.52 KB, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
build.log (11.30 KB, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
mock.log (1002 bytes, text/plain)
2010-02-13 17:24 UTC, FTBFS
no flags Details
patch for implicitDSOLinking (827 bytes, patch)
2010-07-05 06:41 UTC, Jan Klepek
no flags Details | Diff

Description FTBFS 2010-02-13 17:24:04 UTC
driftnet-0.1.6-19.20040426cvs.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 17:24:07 UTC
Created attachment 392625 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 17:24:08 UTC
Created attachment 392626 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 17:24:10 UTC
Created attachment 392627 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 17:24:11 UTC
Created attachment 392628 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 17:24:12 UTC
Created attachment 392629 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 17:24:13 UTC
Created attachment 392630 [details]
mock.log

mock.log for x86_64

Comment 7 Bug Zapper 2010-03-15 14:49:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Jan Klepek 2010-05-04 20:19:14 UTC
Hi Paul,

Any progress with this bug?

Comment 9 Jan Klepek 2010-07-05 06:41:04 UTC
Created attachment 429470 [details]
patch for implicitDSOLinking

Hi Paul,

See attached patch which fixes this issue

Comment 10 Jan Klepek 2010-09-27 15:42:02 UTC
Hi Paul,

I see some changes in git, was this new version builded and update submitted?

Comment 11 Paul Wouters 2010-10-23 23:35:47 UTC
*** Bug 599847 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-10-24 00:09:08 UTC
driftnet-0.1.6-20.20040426cvs.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/driftnet-0.1.6-20.20040426cvs.fc13

Comment 13 Fedora Update System 2010-10-24 00:16:37 UTC
driftnet-0.1.6-20.20040426cvs.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/driftnet-0.1.6-20.20040426cvs.fc12

Comment 14 Fedora Update System 2010-10-24 00:23:35 UTC
driftnet-0.1.6-20.20040426cvs.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/driftnet-0.1.6-20.20040426cvs.fc14

Comment 15 Paul Wouters 2010-10-24 00:25:17 UTC
All branches updated - this would should close when the packages are in stable

Comment 16 Fedora Update System 2010-10-27 22:36:55 UTC
driftnet-0.1.6-20.20040426cvs.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update driftnet'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/driftnet-0.1.6-20.20040426cvs.fc12

Comment 17 Fedora Update System 2010-11-10 01:07:30 UTC
driftnet-0.1.6-20.20040426cvs.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-11-10 01:15:01 UTC
driftnet-0.1.6-20.20040426cvs.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-11-10 01:17:43 UTC
driftnet-0.1.6-20.20040426cvs.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.