Bug 564953 - FTBFS gtest-1.4.0-1.fc13: ImplicitDSOLinking
FTBFS gtest-1.4.0-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtest (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:25 EST by FTBFS
Modified: 2011-03-19 06:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: gtest-1.4.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-28 06:08:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (21.36 KB, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
build.log (29.51 KB, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
mock.log (1020 bytes, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
root.log (24.44 KB, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
build.log (29.42 KB, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
mock.log (1013 bytes, text/plain)
2010-02-13 12:25 EST, FTBFS
no flags Details
linking fix (1.83 KB, patch)
2011-03-19 06:05 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:25:38 EST
gtest-1.4.0-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:25:41 EST
Created attachment 392673 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:25:42 EST
Created attachment 392674 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:25:43 EST
Created attachment 392675 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:25:45 EST
Created attachment 392676 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:25:46 EST
Created attachment 392677 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:25:47 EST
Created attachment 392678 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:49:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:19:47 EDT
Hi Debarshi,

Any progress with this bug?
Comment 9 Debarshi Ray 2010-05-19 02:23:07 EDT
Sorry for having ignored this for so long. I will look at it and fix it by today. Thanks for the reminder.
Comment 10 Dan Horák 2010-08-28 06:08:15 EDT
Fixed with a workaround for gtest 1.4.0, the proper fix for gtest 1.5.0 is to add "lib/libgtest.la" into 2 *_LDADD variables in Makefile.{am,in}.
Comment 11 Terje Røsten 2011-01-16 16:30:30 EST
Hi Dan

I updated gtest to 1.5.0 in rawhide, could you describe the LDADD fix in some
more detail?

The build is here:

 http://koji.fedoraproject.org/koji/buildinfo?buildID=214379

current spec: 

http://pkgs.fedoraproject.org/gitweb/?p=gtest.git;a=blob;f=gtest.spec;h=0250d21b93e3614ee8c54b1eb9f0f4747719259b;hb=3dad48f3af760dd9aa8f5d560c65f523a8eb341c
Comment 12 Dan Horák 2011-03-19 06:05:41 EDT
Created attachment 486372 [details]
linking fix

Hi Terje,

this is IMHO the right fix (explicitly link with the gtest library) and now "make check || :" is sufficient.

Note You need to log in before you can comment on or make changes to this bug.