This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 564959 - FTBFS cairo-clock-0.3.4-4.fc12: ImplicitDSOLinking
FTBFS cairo-clock-0.3.4-4.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cairo-clock (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Benoît Marcelin
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:26 EST by FTBFS
Modified: 2010-06-02 14:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: cairo-clock-0.3.4-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 14:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (478.92 KB, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details
build.log (15.34 KB, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details
mock.log (1.02 KB, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details
root.log (693.53 KB, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details
build.log (15.24 KB, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details
mock.log (975 bytes, text/plain)
2010-02-13 12:26 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:26:44 EST
cairo-clock-0.3.4-4.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:26:48 EST
Created attachment 392709 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:26:49 EST
Created attachment 392710 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:26:50 EST
Created attachment 392711 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:26:52 EST
Created attachment 392712 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:26:53 EST
Created attachment 392713 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:26:54 EST
Created attachment 392714 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:49:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:21:14 EDT
Hi Benoit,

Any progress with this bug?
Comment 9 Benoît Marcelin 2010-06-01 14:22:58 EDT
It's compile successfully for me (I just do a make tag && make scratch-build) ...
I will suggest cairo-clock for updates when make build will finish
Comment 10 Fedora Update System 2010-06-01 14:33:27 EDT
cairo-clock-0.3.4-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cairo-clock-0.3.4-5.fc13
Comment 11 Fedora Update System 2010-06-02 14:14:27 EDT
cairo-clock-0.3.4-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.