Bug 564966 - FTBFS openvas-libnasl-2.0.2-3.fc13: ImplicitDSOLinking
FTBFS openvas-libnasl-2.0.2-3.fc13: ImplicitDSOLinking
Product: Fedora
Classification: Fedora
Component: openvas-libnasl (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
Reported: 2010-02-13 12:28 EST by FTBFS
Modified: 2010-05-04 16:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-05-04 16:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
root.log (95.12 KB, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details
build.log (31.76 KB, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details
mock.log (982 bytes, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details
root.log (140.68 KB, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details
build.log (31.09 KB, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details
mock.log (1.04 KB, text/plain)
2010-02-13 12:28 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:28:06 EST
openvas-libnasl-2.0.2-3.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:28:09 EST
Created attachment 392746 [details]

root.log for i386
Comment 2 FTBFS 2010-02-13 12:28:10 EST
Created attachment 392747 [details]

build.log for i386
Comment 3 FTBFS 2010-02-13 12:28:12 EST
Created attachment 392748 [details]

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:28:13 EST
Created attachment 392749 [details]

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:28:14 EST
Created attachment 392750 [details]

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:28:15 EST
Created attachment 392751 [details]

mock.log for x86_64
Comment 7 Stjepan Gros 2010-02-14 11:11:38 EST
I would suggest that we make transition to OpenVAS 3. Is it possible?
Comment 8 Huzaifa S. Sidhpurwala 2010-02-18 01:49:28 EST
yeah we should do that.
Comment 9 Huzaifa S. Sidhpurwala 2010-02-18 01:52:36 EST
since there is no openvas-libnasl 3.0, this FTBS will need to be taken care of
Comment 10 Stjepan Gros 2010-02-18 08:30:24 EST
libnasl doesn't exist as a separate component in OpenVAS 3 any more. So, if we transition to new version this can be closed as WONTFIX because there is no point in fixing it.
Comment 11 Bug Zapper 2010-03-15 10:50:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
Comment 12 Jan Klepek 2010-05-04 16:23:20 EDT
Closing as openvas-libnasl is replaced wit OpenVAS3.

Note You need to log in before you can comment on or make changes to this bug.