Bug 56498 - cpqarray.o fails to load during boot with error: init_module: Input/Output error
cpqarray.o fails to load during boot with error: init_module: Input/Output error
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-19 20:45 EST by ctolley
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-11 15:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -v output (3.91 KB, text/plain)
2001-12-10 20:46 EST, ctolley
no flags Details
dmesg outupt (9.51 KB, text/plain)
2001-12-10 20:53 EST, ctolley
no flags Details

  None (edit)
Description ctolley 2001-11-19 20:45:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Installed both i386 and i686 kernel version 2.4.9-13 with the same 
results.  Server is a Compaq Proliant 5500 with a single P-III 500 Xeon 
CPU, 3.5GB RAM, 3200 Compaq RAID Array.

Kernel 2.4.7 has no problems.  Downloaded, compiled and tested kernel-
2.4.13-0.5 and encountered no problems.  Recompiled both i686 and i386 
versions of kernel-2.4.9-13 on this server while running kernel 2.4.7, but 
recompiled kernel had the same problem.

We tried different types of RAID controllers (all Compaq, but different 
model #'s).  All produced the same error.  kernel-2.4.9-13 on a non Xeon 
system with similar RAID had no problems.  I suspect it is something about 
the Xeon processor, but I have no way to determine that, as the mainboard 
prevents us from putting anything but a Xeon in it.  kernel-2.4.9-13 
worked fine on a Compaq Proliant 1850R (P-III 500 non-Xeon) with the same 
RAID devices.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install stock RH7.2 (kernel-2.4.7-10)
2. Install i686 version of kernel-2.4.9-13
3. Choose kernel-2.4.9-13 during next boot and watch the kernel-panic

Actual Results:  Tried installing the kernel-debug-2.4.9-13 but it 
produced no more output on the insmod failure than the non-debug kernel 
(which is to say it only output the init_module error).  I'm not familiar 
with the debugger, so I didn't get any farther than that.

I considered just applying cpqarray_2.4.20D_for_2.4.9.patch from Compaq, 
but there were about 6 other patches that were already being applied that 
effected the key files related to the cpqarray, so the patch from Compaq 
wouldn't work...and I didn't want to create a patch to your patches...

Expected Results:  Kernel should install with little error on all i386 and 
better Intel architectures.

Additional info:

I'm going to experiment with removing the specific pieces of each of those 
patches that deal with cpqarray.h, cpqarray.c, genhd.c, ida_ioctl.h and 
smart1,2.h until I can successfully apply 
cpqarray_2.4.20D_for_2.4.9.patch.  I'm open for any useful suggestions or 
assistance...perhaps a debugger command that might produce some useful 
output after the panic?
Comment 1 Arjan van de Ven 2001-11-20 04:07:35 EST
can you attach "lspci" and "lspci -v" output ? (from the working kernel?)
Comment 2 ctolley 2001-12-10 20:46:26 EST
Created attachment 40328 [details]
lspci -v output
Comment 3 ctolley 2001-12-10 20:49:51 EST
Some added info on the kernel problems I'm experiencing.  Aside from not being 
able to get 2.4.9-13 to work at all, 2.4.7-10 that ships with RH7.2 doesn't 
detect SMP.  The BOOT kernel that the installer uses detects SMP to the point 
that it knows to install the SMP kernel, but when the server boots after 
install, the SMP kernel doesn't detect an SMP capable motherboard.

I'll attach the dmesg output of the boot.
Comment 4 ctolley 2001-12-10 20:53:48 EST
Created attachment 40329 [details]
dmesg outupt
Comment 5 ctolley 2001-12-11 15:41:14 EST
Thanks for the new kernel.  It boots well and I no longer have the problem 
loading cpqarray.o.  However, even with adding "acpismp=force" (minus the 
quotes, of course) to both the enterprise and smp kernel lines of grub.conf, 
the system still fails to detect the 2nd CPU (still says that an SMP 
motherboard isn't detected).

Is there any output from anything that I can give you to help me work this 
problem out?  Should we move this problem to a new bug report or continue to 
work from here?
Comment 6 ctolley 2001-12-20 18:28:25 EST
Finally met with some Compaq reps on this.  There was a buried BIOS option for 
APIC settings.  Turns out the APIC was disabled on the motherboard.  Once Full 
Map was enabled, SMP was detected and the additional CPU's were detected.

Thanks for your time and assistance in this.


Note You need to log in before you can comment on or make changes to this bug.