Bug 564997 - FTBFS paperbox-0.4.3-2.fc12
Summary: FTBFS paperbox-0.4.3-2.fc12
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: paperbox
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Gareth John
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Reopened, Triaged
Depends On:
Blocks: F13FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-02-13 17:34 UTC by FTBFS
Modified: 2010-06-03 16:08 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-03 16:04:38 UTC


Attachments (Terms of Use)
root.log (1.03 MB, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details
build.log (97.57 KB, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details
mock.log (955 bytes, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details
root.log (1.54 MB, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details
build.log (98.22 KB, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details
mock.log (963 bytes, text/plain)
2010-02-13 17:34 UTC, FTBFS
no flags Details

Description FTBFS 2010-02-13 17:34:12 UTC
paperbox-0.4.3-2.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 17:34:18 UTC
Created attachment 392927 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 17:34:20 UTC
Created attachment 392928 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 17:34:21 UTC
Created attachment 392929 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 17:34:24 UTC
Created attachment 392930 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 17:34:25 UTC
Created attachment 392931 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 17:34:26 UTC
Created attachment 392932 [details]
mock.log

mock.log for x86_64

Comment 7 Gareth John 2010-02-26 17:18:34 UTC
Reported upstream

Comment 8 Hicham HAOUARI 2010-04-23 16:45:20 UTC
i don't think you can close it unless it is fixed, reopening

Comment 9 Mamoru TASAKA 2010-04-23 18:26:21 UTC
For F-13, adding

sed -i.deprecated \
	-e '/-DGTKMM_DISABLE_DEPRECATED/d' \
	src/Makefile.in

at the end of %prep make paperbox build succeed.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2134497

(Or change
 tile_view_->get_page_navigator().get_button_first().clicked();
 to
 gtk_button_clicked(gobj(tile_view_->get_page_navigator().get_button_first()));
 and change the rest similarly)

Comment 10 Gareth John 2010-04-29 22:44:46 UTC
Hi Mamoru will make the addition required tomorrow sorry for the long delay. I have reported bugs upstream. It appears no fix will be made though.

Comment 11 Gareth John 2010-04-29 22:47:22 UTC
*** Bug 586660 has been marked as a duplicate of this bug. ***

Comment 12 Hicham HAOUARI 2010-04-30 00:07:02 UTC
@ Gareth,

Note that is the spec file you should change BR from tracker-devel to compat-tracker-devel

Comment 13 Hicham HAOUARI 2010-04-30 00:12:31 UTC
s/is/in/

Comment 14 Gareth John 2010-04-30 07:52:22 UTC
Yes, I will retire the package later anyway!

Comment 15 Matt Domsch 2010-06-03 16:04:38 UTC
This package is no longer in Fedora 14's rawhide.  Please add a dead.package to its devel/ branch in CVS.

Comment 16 Hicham HAOUARI 2010-06-03 16:08:40 UTC
@ Matt Domsch,

If you are a proven packager, do it


Note You need to log in before you can comment on or make changes to this bug.