Bug 565028 - FTBFS cluster-3.0.7-1.fc13: ImplicitDSOLinking
Summary: FTBFS cluster-3.0.7-1.fc13: ImplicitDSOLinking
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: cluster (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 564245
TreeView+ depends on / blocked
 
Reported: 2010-02-13 17:40 UTC by FTBFS
Modified: 2010-02-15 10:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 10:52:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (337.46 KB, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details
build.log (140.56 KB, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details
mock.log (951 bytes, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details
root.log (426.01 KB, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details
build.log (138.38 KB, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details
mock.log (959 bytes, text/plain)
2010-02-13 17:40 UTC, FTBFS
no flags Details

Description FTBFS 2010-02-13 17:40:21 UTC
cluster-3.0.7-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 17:40:24 UTC
Created attachment 393098 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 17:40:25 UTC
Created attachment 393099 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 17:40:27 UTC
Created attachment 393100 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 17:40:28 UTC
Created attachment 393101 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 17:40:29 UTC
Created attachment 393102 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 17:40:30 UTC
Created attachment 393103 [details]
mock.log

mock.log for x86_64

Comment 7 Fabio Massimo Di Nitto 2010-02-15 10:53:11 UTC
http://git.fedorahosted.org/git/?p=cluster.git;a=commitdiff;h=45e4d971b97376392ba8c4053c7cfb6e99c19f34

will be part of the next release that will be available no later than next week.


Note You need to log in before you can comment on or make changes to this bug.