Bug 565031 - FTBFS gimp-2.6.8-3.fc13: ImplicitDSOLinking
FTBFS gimp-2.6.8-3.fc13: ImplicitDSOLinking
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:40 EST by FTBFS
Modified: 2010-03-24 06:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-24 06:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (1.07 MB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
build.log (158.94 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
mock.log (939 bytes, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
root.log (1.63 MB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
build.log (154.83 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
mock.log (947 bytes, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:40:57 EST
gimp-2.6.8-3.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:41:01 EST
Created attachment 393116 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:41:02 EST
Created attachment 393117 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:41:03 EST
Created attachment 393118 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:41:07 EST
Created attachment 393119 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:41:08 EST
Created attachment 393120 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:41:09 EST
Created attachment 393121 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:52:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Nils Philippsen 2010-03-24 06:52:42 EDT
This is fixed now (2.6.8-5.fc13)

Note You need to log in before you can comment on or make changes to this bug.