Bug 565035 - FTBFS gcin-1.4.6-1.fc13: ImplicitDSOLinking
FTBFS gcin-1.4.6-1.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcin (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Chung-Yen Chang
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:41 EST by FTBFS
Modified: 2010-05-16 21:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-16 21:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (532.75 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
build.log (78.12 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
mock.log (938 bytes, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
root.log (792.48 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
build.log (76.18 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 12:41 EST, FTBFS
no flags Details
patch to add -lm to LDFLAGS (749 bytes, patch)
2010-04-22 00:22 EDT, Daiki Ueno
no flags Details | Diff
patch to stop using GTK+ deprecated API (5.17 KB, patch)
2010-04-22 01:16 EDT, Daiki Ueno
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:41:44 EST
gcin-1.4.6-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:41:47 EST
Created attachment 393140 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:41:48 EST
Created attachment 393141 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:41:50 EST
Created attachment 393142 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:41:51 EST
Created attachment 393143 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:41:53 EST
Created attachment 393144 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:41:54 EST
Created attachment 393145 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:53:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Daiki Ueno 2010-04-22 00:21:57 EDT
Cairo apparently uses log() from -lm, which needs to be explicitly linked with gcin in F-13.

Even that is fixed, gcin does not build against gtk+-2.20 in F-13 because gcin uses deprecated API - gcin Makefile passes -DGTK_DISABLE_DEPRECATED to gcc.

I'll attach a couple of patches: one (configure.patch) is an updated version of the existing configure.patch, and another (gtk-deprecated.patch) addresses the deprecated API issue.

I've tested the build (with patches) against dist-f11, dist-f12, and dist-f13, and all went well:

https://koji.fedoraproject.org/koji/taskinfo?taskID=2131423
https://koji.fedoraproject.org/koji/taskinfo?taskID=2131411
https://koji.fedoraproject.org/koji/taskinfo?taskID=2131428

Hope this helps.
Comment 9 Daiki Ueno 2010-04-22 00:22:57 EDT
Created attachment 408230 [details]
patch to add -lm to LDFLAGS
Comment 10 Daiki Ueno 2010-04-22 01:16:12 EDT
Created attachment 408234 [details]
patch to stop using GTK+ deprecated API
Comment 11 Jan Klepek 2010-05-04 16:34:45 EDT
Hi Chung-Yen,

any progress with new package update?
Comment 12 Chung-Yen Chang 2010-05-04 22:22:58 EDT
new package update with those two patchs built
Comment 13 Daiki Ueno 2010-05-06 02:20:18 EDT
The new package pushed by Chung-Yen seems to work fine here.
I'm moving this bug to MODIFIED.
Comment 14 Daiki Ueno 2010-05-16 21:03:57 EDT
I noticed that the new package was moved to the F-13 stable repository.
Closing.

Note You need to log in before you can comment on or make changes to this bug.