Bug 565037 - FTBFS pcmanfm-0.5.2-1.fc13: ImplicitDSOLinking
Summary: FTBFS pcmanfm-0.5.2-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pcmanfm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 564245
TreeView+ depends on / blocked
 
Reported: 2010-02-13 17:42 UTC by FTBFS
Modified: 2010-02-14 02:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-13 17:57:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (541.84 KB, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details
build.log (140.53 KB, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details
mock.log (951 bytes, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details
root.log (759.96 KB, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details
build.log (140.44 KB, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details
mock.log (958 bytes, text/plain)
2010-02-13 17:42 UTC, FTBFS
no flags Details

Description FTBFS 2010-02-13 17:42:05 UTC
pcmanfm-0.5.2-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 17:42:08 UTC
Created attachment 393152 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 17:42:10 UTC
Created attachment 393153 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 17:42:11 UTC
Created attachment 393154 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 17:42:13 UTC
Created attachment 393155 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 17:42:14 UTC
Created attachment 393156 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 17:42:15 UTC
Created attachment 393157 [details]
mock.log

mock.log for x86_64

Comment 7 Mamoru TASAKA 2010-02-13 17:57:41 UTC
I REALLY appreciate if you would wait a day or two day before trying
to rush to file these bugs to give maintainers time to work on
these.

Comment 8 FTBFS 2010-02-14 02:16:03 UTC
I don't see the harm in filing a bug when there's a problem, even if the maintainer does jump in and fix it quickly.  Otherwise, you're asking me to keep track of failures, in my own head or build system, separate from bugzilla, for a while, when that's exactly what bugzilla exists for.

You're welcome to complain on the devel@ list about my practices, and recommend a better process there.  If there's consensus that I need to change the way I file bugs, then I'll do so.


Note You need to log in before you can comment on or make changes to this bug.