Bug 565041 - FTBFS gnubversion-0.5-7.fc11: ImplicitDSOLinking
FTBFS gnubversion-0.5-7.fc11: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnubversion (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583276
  Show dependency treegraph
 
Reported: 2010-02-13 12:42 EST by FTBFS
Modified: 2010-05-05 07:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 07:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (937.79 KB, text/plain)
2010-02-13 12:42 EST, FTBFS
no flags Details
build.log (123.56 KB, text/plain)
2010-02-13 12:42 EST, FTBFS
no flags Details
mock.log (961 bytes, text/plain)
2010-02-13 12:42 EST, FTBFS
no flags Details
root.log (1.38 MB, text/plain)
2010-02-13 12:43 EST, FTBFS
no flags Details
build.log (119.99 KB, text/plain)
2010-02-13 12:43 EST, FTBFS
no flags Details
mock.log (969 bytes, text/plain)
2010-02-13 12:43 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:42:52 EST
gnubversion-0.5-7.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:42:56 EST
Created attachment 393176 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:42:57 EST
Created attachment 393177 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:42:59 EST
Created attachment 393178 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:43:02 EST
Created attachment 393179 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:43:04 EST
Created attachment 393180 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:43:05 EST
Created attachment 393181 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:53:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:12:40 EDT
Hi,

Any progress on fixing this bug?
Comment 9 Xavier Lamien 2010-05-05 07:04:19 EDT
Hey,

Yep, new builds (0.5-9) are on their way for F-13 and rawhide.
Thanks for the heads up.

Note You need to log in before you can comment on or make changes to this bug.