Bug 565053 - FTBFS pioneers-0.12.2-4.fc12: ImplicitDSOLinking
FTBFS pioneers-0.12.2-4.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pioneers (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:45 EST by FTBFS
Modified: 2010-03-10 01:56 EST (History)
1 user (show)

See Also:
Fixed In Version: pioneers-0.12.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-10 01:56:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (673.37 KB, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details
build.log (122.72 KB, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details
mock.log (958 bytes, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details
root.log (978.45 KB, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details
build.log (119.57 KB, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details
mock.log (966 bytes, text/plain)
2010-02-13 12:45 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:45:08 EST
pioneers-0.12.2-4.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:45:11 EST
Created attachment 393245 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:45:13 EST
Created attachment 393246 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:45:14 EST
Created attachment 393247 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:45:16 EST
Created attachment 393248 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:45:17 EST
Created attachment 393249 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:45:18 EST
Created attachment 393250 [details]
mock.log

mock.log for x86_64
Comment 7 Fedora Update System 2010-02-17 09:03:22 EST
pioneers-0.12.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pioneers-0.12.3-1.fc13
Comment 8 Fedora Update System 2010-02-19 19:07:05 EST
pioneers-0.12.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pioneers'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-1346
Comment 9 Fedora Update System 2010-03-10 01:56:07 EST
pioneers-0.12.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.