Bug 565064 - FTBFS crypto-utils-2.4.1-23: ImplicitDSOLinking
FTBFS crypto-utils-2.4.1-23: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: crypto-utils (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:47 EST by FTBFS
Modified: 2010-03-27 17:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 17:01:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (109.64 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
build.log (6.32 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
root.log (151.62 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
build.log (6.02 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
mock.log (1.02 KB, text/plain)
2010-02-13 12:47 EST, FTBFS
no flags Details
Add explicit linker flags to fix the build (2.79 KB, patch)
2010-02-13 21:52 EST, Elio Maldonado Batiz
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:47:16 EST
crypto-utils-2.4.1-23.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:47:19 EST
Created attachment 393311 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:47:20 EST
Created attachment 393312 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:47:21 EST
Created attachment 393313 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:47:23 EST
Created attachment 393314 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:47:24 EST
Created attachment 393315 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:47:25 EST
Created attachment 393316 [details]
mock.log

mock.log for x86_64
Comment 7 Elio Maldonado Batiz 2010-02-13 21:52:30 EST
Created attachment 394178 [details]
Add explicit linker flags to fix the build

I have checked in those changes, tagged and it built okay
http://koji.fedoraproject.org/koji/taskinfo?taskID=1984858
Comment 8 Bug Zapper 2010-03-15 10:54:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bruno Wolff III 2010-03-27 17:01:01 EDT
I think this is safe to close now.
Thanks for fixing things.

Note You need to log in before you can comment on or make changes to this bug.