Bug 565071 - FTBFS powermanga-0.90-7: ImplicitDSOLinking
FTBFS powermanga-0.90-7: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: powermanga (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583278
  Show dependency treegraph
 
Reported: 2010-02-13 12:48 EST by FTBFS
Modified: 2010-04-30 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 10:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (379.21 KB, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
build.log (29.19 KB, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
mock.log (1022 bytes, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
root.log (589.10 KB, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
build.log (27.79 KB, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
mock.log (953 bytes, text/plain)
2010-02-13 12:48 EST, FTBFS
no flags Details
Makefile.in patch (652 bytes, patch)
2010-04-24 15:23 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch (575 bytes, patch)
2010-04-24 15:24 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:48:34 EST
powermanga-0.90-7.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:48:38 EST
Created attachment 393353 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:48:39 EST
Created attachment 393354 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:48:40 EST
Created attachment 393355 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:48:42 EST
Created attachment 393356 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:48:43 EST
Created attachment 393357 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:48:45 EST
Created attachment 393358 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:54:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-24 15:23:35 EDT
Created attachment 408872 [details]
Makefile.in patch

As part of my Fedora engineering services tasks I took a look at this ticket.
I have attached patches for src/Makefile.in (to make the build work) and src/Makefile.am (for upstream).
Comment 9 Bruno Wolff III 2010-04-24 15:24:25 EDT
Created attachment 408873 [details]
Makefile.am patch
Comment 10 Matthias Saou 2010-04-30 10:38:13 EDT
I actually already took care of this a few days ago while looking at another problem. Thanks anyway!

Note You need to log in before you can comment on or make changes to this bug.