Bug 565081 - FTBFS griv-0.1.9-7.fc12: ImplicitDSOLinking
FTBFS griv-0.1.9-7.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: griv (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Josephine Tannhäuser
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583278
  Show dependency treegraph
 
Reported: 2010-02-13 12:50 EST by FTBFS
Modified: 2010-11-21 16:52 EST (History)
3 users (show)

See Also:
Fixed In Version: griv-0.1.9-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 11:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (465.20 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
build.log (17.48 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
mock.log (939 bytes, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
root.log (656.81 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
build.log (17.38 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
mock.log (947 bytes, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
Makefile.in patch (451 bytes, patch)
2010-04-24 16:19 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch (364 bytes, patch)
2010-04-24 16:20 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:50:29 EST
griv-0.1.9-7.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:50:32 EST
Created attachment 393410 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:50:33 EST
Created attachment 393411 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:50:35 EST
Created attachment 393412 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:50:36 EST
Created attachment 393413 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:50:38 EST
Created attachment 393414 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:50:39 EST
Created attachment 393415 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:55:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-24 16:19:45 EDT
Created attachment 408879 [details]
Makefile.in patch

As part of my Fedora engineering services tasks I took a look at this bug.
I have attached patches for src/Makefile.in (to get the build to work) and src/Makefile.am (for upstream).
Comment 9 Bruno Wolff III 2010-04-24 16:20:38 EDT
Created attachment 408880 [details]
Makefile.am patch
Comment 10 Fedora Update System 2010-04-29 13:15:21 EDT
griv-0.1.9-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/griv-0.1.9-8.fc13
Comment 11 Fedora Update System 2010-04-30 19:41:38 EDT
griv-0.1.9-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update griv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/griv-0.1.9-8.fc13
Comment 12 Matt Domsch 2010-06-03 11:37:32 EDT
griv-0.1.9-8.fc14.src.rpm
builds in rawhide.
Comment 13 Fedora Update System 2010-11-21 16:52:33 EST
griv-0.1.9-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.