Bug 565082 - FTBFS rb_libtorrent-0.14.8-2.fc13: ImplicitDSOLinking
FTBFS rb_libtorrent-0.14.8-2.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rb_libtorrent (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583278
  Show dependency treegraph
 
Reported: 2010-02-13 12:50 EST by FTBFS
Modified: 2010-06-07 18:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: deluge-1.2.3-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 18:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (158.27 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
build.log (370.47 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
mock.log (978 bytes, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
root.log (224.55 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
build.log (358.51 KB, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
mock.log (987 bytes, text/plain)
2010-02-13 12:50 EST, FTBFS
no flags Details
Spec file patch (1.02 KB, patch)
2010-04-25 14:06 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.in patch to get build to work. (610 bytes, patch)
2010-04-25 14:07 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch that should go upstream. (542 bytes, patch)
2010-04-25 14:08 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:50:40 EST
rb_libtorrent-0.14.8-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:50:43 EST
Created attachment 393416 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:50:45 EST
Created attachment 393417 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:50:46 EST
Created attachment 393418 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:50:47 EST
Created attachment 393419 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:50:49 EST
Created attachment 393420 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:50:50 EST
Created attachment 393421 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:55:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-25 14:06:11 EDT
Created attachment 408987 [details]
Spec file patch

As part of my Fedora Engineering Services tasks I took a look at this bug.
I was able to get a rpmbuild -ba to work and am attaching the appropriate patches. These are against 0.14.10 from the f12 srpm.
Because the f12 version is currently higher than the f13 version, it would be nice to get this fixed before the release so that updates occur smoothly.
I put my name on the sample change log entry in the spec file, feel free to drop that if you want.
Comment 9 Bruno Wolff III 2010-04-25 14:07:11 EDT
Created attachment 408988 [details]
Makefile.in patch to get build to work.
Comment 10 Bruno Wolff III 2010-04-25 14:08:14 EDT
Created attachment 408989 [details]
Makefile.am patch that should go upstream.
Comment 11 Fedora Update System 2010-05-28 05:48:39 EDT
deluge-1.2.3-2.fc13,rb_libtorrent-0.14.10-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/deluge-1.2.3-2.fc13,rb_libtorrent-0.14.10-3.fc13
Comment 12 Fedora Update System 2010-05-28 14:05:47 EDT
deluge-1.2.3-2.fc13, rb_libtorrent-0.14.10-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update deluge rb_libtorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/deluge-1.2.3-2.fc13,rb_libtorrent-0.14.10-3.fc13
Comment 13 Fedora Update System 2010-06-07 18:18:21 EDT
deluge-1.2.3-2.fc13, rb_libtorrent-0.14.10-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.