Bug 565084 - FTBFS libimobiledevice-0.9.7-2.fc13: ImplicitDSOLinking
FTBFS libimobiledevice-0.9.7-2.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libimobiledevice (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:51 EST by FTBFS
Modified: 2010-02-15 03:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 03:22:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (107.76 KB, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details
build.log (48.14 KB, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details
mock.log (987 bytes, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details
root.log (175.21 KB, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details
build.log (47.10 KB, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details
mock.log (995 bytes, text/plain)
2010-02-13 12:51 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:51:03 EST
libimobiledevice-0.9.7-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:51:07 EST
Created attachment 393428 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:51:08 EST
Created attachment 393429 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:51:09 EST
Created attachment 393430 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:51:10 EST
Created attachment 393431 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:51:12 EST
Created attachment 393432 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:51:13 EST
Created attachment 393433 [details]
mock.log

mock.log for x86_64
Comment 7 Peter Robinson 2010-02-15 03:22:41 EST
Fixed and built in rawhide

http://koji.fedoraproject.org/koji/taskinfo?taskID=1986933

Note You need to log in before you can comment on or make changes to this bug.