Bug 565114 - FTBFS ristretto-0.0.22-2.fc12: ImplicitDSOLinking
FTBFS ristretto-0.0.22-2.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ristretto (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:57 EST by FTBFS
Modified: 2010-11-25 15:30 EST (History)
1 user (show)

See Also:
Fixed In Version: ristretto-0.0.22-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 18:34:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (886.52 KB, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details
build.log (23.29 KB, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details
mock.log (962 bytes, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details
root.log (1.18 MB, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details
build.log (23.09 KB, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details
mock.log (970 bytes, text/plain)
2010-02-13 12:57 EST, FTBFS
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6873 None None None Never

  None (edit)
Description FTBFS 2010-02-13 12:57:05 EST
ristretto-0.0.22-2.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:57:08 EST
Created attachment 393602 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:57:10 EST
Created attachment 393603 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:57:11 EST
Created attachment 393604 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:57:13 EST
Created attachment 393605 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:57:15 EST
Created attachment 393606 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:57:16 EST
Created attachment 393607 [details]
mock.log

mock.log for x86_64
Comment 7 Fedora Update System 2010-02-17 18:39:59 EST
ristretto-0.0.22-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ristretto-0.0.22-3.fc13
Comment 8 Fedora Update System 2010-02-25 07:49:15 EST
ristretto-0.0.22-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Christoph Wickert 2010-11-25 15:30:58 EST
Reported upstream at http://bugzilla.xfce.org/show_bug.cgi?id=6873

Note You need to log in before you can comment on or make changes to this bug.