This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 565122 - FTBFS bzflag-2.0.12-6.fc12: ImplicitDSOLinking
FTBFS bzflag-2.0.12-6.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bzflag (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:58 EST by FTBFS
Modified: 2010-03-09 11:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-09 11:12:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (392.28 KB, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
build.log (296.40 KB, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
mock.log (950 bytes, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
root.log (562.82 KB, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
build.log (271.84 KB, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
mock.log (957 bytes, text/plain)
2010-02-13 12:58 EST, FTBFS
no flags Details
explicitly link bzfs with libdl (335 bytes, patch)
2010-03-08 12:09 EST, Jeff Makey
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 12:58:32 EST
bzflag-2.0.12-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:58:35 EST
Created attachment 393650 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:58:37 EST
Created attachment 393651 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:58:38 EST
Created attachment 393652 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:58:40 EST
Created attachment 393653 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:58:41 EST
Created attachment 393654 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:58:42 EST
Created attachment 393655 [details]
mock.log

mock.log for x86_64
Comment 7 Jeff Makey 2010-03-08 12:09:13 EST
Created attachment 398567 [details]
explicitly link bzfs with libdl

This patch (against the 2.0.14 release of BZFlag) simply ensures that bzfs is explicitly linked with the dl library, and should fix this bug.  A more general solution that includes -ldl only when necessary has been committed upstream and will be part of any future BZFlag releases.
Comment 8 Nils Philippsen 2010-03-09 10:08:19 EST
Thanks for the patch. I extended it so that the Makefile.am is patched to have a matching bzflag_LIBADD line. I'm just trying it out in mock and will commit/build if that works.
Comment 9 Nils Philippsen 2010-03-09 10:36:03 EST
Committed to Rawhide, F-11,12,13, building.

Note You need to log in before you can comment on or make changes to this bug.