Bug 565128 - FTBFS gnome-games-2.29.6-1.fc13: ImplicitDSOLinking
FTBFS gnome-games-2.29.6-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 12:59 EST by FTBFS
Modified: 2011-01-26 04:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-14 01:47:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (1.06 MB, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details
build.log (120.30 KB, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details
mock.log (1.02 KB, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details
root.log (1.58 MB, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details
build.log (118.47 KB, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details
mock.log (979 bytes, text/plain)
2010-02-13 12:59 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 12:59:43 EST
gnome-games-2.29.6-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:59:47 EST
Created attachment 393686 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:59:49 EST
Created attachment 393687 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:59:50 EST
Created attachment 393688 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:59:53 EST
Created attachment 393689 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:59:54 EST
Created attachment 393690 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:59:55 EST
Created attachment 393691 [details]
mock.log

mock.log for x86_64
Comment 7 John Freed 2011-01-26 04:42:15 EST
I'm a fan of swell-foop and see it's not in the gnome-games package for FC14. I tried to build from the latest source and got the same problem reported by FTBFS for gnect -- it needs to be explicitly linked against zlib. I know enough that I can add it manually to the Makefile in gnect/src but not enough to know whether this is a Fedora or a Gnome Games problem.

Also, all the games build and work except lightsoff, swell-foop and gnibbles. The first two seem to have a problem with GtkClutter, and there were changes reported in October-November 2010 in that package that supposedly resolved earlier bugs. I plan to investigate that.

As to gnibbles, it seems to have screen-draw problems. But I think the other games can be re-included in the package.

Note You need to log in before you can comment on or make changes to this bug.