Bug 565140 - FTBFS openswan-2.6.24-2.fc13: ImplicitDSOLinking
FTBFS openswan-2.6.24-2.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openswan (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Avesh Agarwal
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 574839
  Show dependency treegraph
 
Reported: 2010-02-13 13:02 EST by FTBFS
Modified: 2010-04-13 21:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: openswan-2.6.24-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 574839 (view as bug list)
Environment:
Last Closed: 2010-02-18 13:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (112.42 KB, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details
build.log (311.66 KB, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details
mock.log (958 bytes, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details
root.log (155.91 KB, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details
build.log (304.11 KB, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details
mock.log (965 bytes, text/plain)
2010-02-13 13:02 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 13:02:15 EST
openswan-2.6.24-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:02:18 EST
Created attachment 393758 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:02:20 EST
Created attachment 393759 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:02:21 EST
Created attachment 393760 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:02:23 EST
Created attachment 393761 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:02:24 EST
Created attachment 393762 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:02:26 EST
Created attachment 393763 [details]
mock.log

mock.log for x86_64
Comment 7 Fedora Update System 2010-02-26 15:00:44 EST
openswan-2.6.24-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openswan-2.6.24-3.fc13
Comment 8 Fedora Update System 2010-02-26 15:01:10 EST
openswan-2.6.24-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openswan-2.6.24-3.fc13
Comment 9 Fedora Update System 2010-04-13 21:39:26 EDT
openswan-2.6.24-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.