Bug 565159 - FTBFS fence-agents-3.0.7-1.fc13: ImplicitDSOLinking
FTBFS fence-agents-3.0.7-1.fc13: ImplicitDSOLinking
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: fence-agents (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Fabio Massimo Di Nitto
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 13:05 EST by FTBFS
Modified: 2010-02-15 05:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 05:54:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (278.74 KB, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details
build.log (7.07 KB, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details
mock.log (971 bytes, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details
root.log (365.14 KB, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details
build.log (6.98 KB, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details
mock.log (978 bytes, text/plain)
2010-02-13 13:05 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 13:05:50 EST
fence-agents-3.0.7-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:05:53 EST
Created attachment 393869 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:05:54 EST
Created attachment 393870 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:05:55 EST
Created attachment 393871 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:05:57 EST
Created attachment 393872 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:05:58 EST
Created attachment 393873 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:05:59 EST
Created attachment 393874 [details]
mock.log

mock.log for x86_64
Comment 7 Fabio Massimo Di Nitto 2010-02-15 05:54:06 EST
http://git.fedorahosted.org/git/?p=cluster.git;a=commitdiff;h=055f365d0bb4146ee59997682dcb35e526a92c15

will be available in the next release within next week.

Note You need to log in before you can comment on or make changes to this bug.